re = /^(?<email>(?<before>[\p{L}0-9.-@#$%!_]+)@(?<after>gmail|hotmail|yahoo)(.com|.nl|.info))$/
str = 'test@gmail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end