$re = '/^(?<email>(?<before>[\p{L}0-9.-@#$%!_]+)@(?<after>gmail|hotmail|yahoo)(.com|.nl|.info))$/';
$str = 'test@gmail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);