#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s){% tag \w+ %}(?:(?:(?!{%).)|(?0))*{% endtag %}"
Local $sString = "{% tag xyz %}" & @CRLF & _
"}" & @CRLF & _
" {% tag abc %}" & @CRLF & _
" {% endtag %}" & @CRLF & _
"{" & @CRLF & _
"{% endtag %}" & @CRLF & _
"" & @CRLF & _
"abc" & @CRLF & _
"" & @CRLF & _
"{% tag abc %}1{% endtag %}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")