$re = '/{% tag \w+ %}(?:(?:(?!{%).)|(?0))*{% endtag %}/s';
$str = '{% tag xyz %}
}
{% tag abc %}
{% endtag %}
{
{% endtag %}
abc
{% tag abc %}1{% endtag %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);