re = /{% tag \w+ %}(?:(?:(?!{%).)|(?0))*{% endtag %}/
str = '{% tag xyz %}
}
{% tag abc %}
{% endtag %}
{
{% endtag %}
abc
{% tag abc %}1{% endtag %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end