package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*([^:\s]+\s+[^:\s]+)\s*(?:\([^()]*\))?:\s*(\S*)\s*(\w+)`)
var str = `%DATA-4-JSON: POP 0/1/0 (1: object): JSON object data`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}