re = /\s*([^:\s]+\s+[^:\s]+)\s*(?:\([^()]*\))?:\s*(\S*)\s*(\w+)/
str = '%DATA-4-JSON: POP 0/1/0 (1: object): JSON object data'
# Print the match result
str.match(re) do |match|
puts match.to_s
end