const regex = /\s*([^:\s]+\s+[^:\s]+)\s*(?:\([^()]*\))?:\s*(\S*)\s*(\w+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*([^:\\s]+\\s+[^:\\s]+)\\s*(?:\\([^()]*\\))?:\\s*(\\S*)\\s*(\\w+)', '')
const str = `%DATA-4-JSON: POP 0/1/0 (1: object): JSON object data`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}