using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\/\*A-Z0-9_\s]*(?=\{)\{CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9]))).+(?=(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))))";
string input = @"/* UACK */ {CAN_SID_UACK_IDT1S03, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */
{RSTART_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}