import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\/\\*A-Z0-9_\\s]*(?=\\{)\\{CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9]))).+(?=(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))))";
final String string = "/* UACK */ {CAN_SID_UACK_IDT1S03, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */\n"
+ " {RSTART_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}