import re
regex = re.compile(r"[\/\*A-Z0-9_\s]*(?=\{)\{CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9]))).+(?=(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))))", flags=re.MULTILINE)
test_str = ("/* UACK */ {CAN_SID_UACK_IDT1S03, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */\n"
" {RSTART_")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")