use strict;
my $str = 'Dit
is een
test met een
tekst met
verschillende
nieuwe regels.
';
my $regex = qr/^\s+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";