re = /^\s+$/m
str = 'Dit
is een
test met een
tekst met
verschillende
nieuwe regels.
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result