$re = '/^\s+$/m';
$str = 'Dit
is een
test met een
tekst met
verschillende
nieuwe regels.
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;