package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s_{1}([a-zA-Z0-9]+)\b`)
var str = `Calculate the _area of the _perfectRectangle object.
The _id and _age variables are both integers.
__invalidVariable _evenMoreInvalidVariable_ _validVariable`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}