// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s_{1}([a-zA-Z0-9]+)\b").unwrap();
let string = "Calculate the _area of the _perfectRectangle object.
The _id and _age variables are both integers.
__invalidVariable _evenMoreInvalidVariable_ _validVariable";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}