const regex = /\s_{1}([a-zA-Z0-9]+)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s_{1}([a-zA-Z0-9]+)\\b', 'gm')
const str = `Calculate the _area of the _perfectRectangle object.
The _id and _age variables are both integers.
__invalidVariable _evenMoreInvalidVariable_ _validVariable`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}