package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)/\b(?:https?:\/\/)?[^\/:]+\/.*?atendimento/documentos`)
var str = `https://localhost:8000/atendimento/documentos/declaracao`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}