re = /\/\b(?:https?:\/\/)?[^\/:]+\/.*?atendimento\/documentos/i
str = 'https://localhost:8000/atendimento/documentos/declaracao'
# Print the match result
str.match(re) do |match|
puts match.to_s
end