using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__(.*?)__";
string input = @"The quick __grey__ fox jumps over the lazy __brown__ dog";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}