package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`__(.*?)__`)
var str = `The quick __grey__ fox jumps over the lazy __brown__ dog`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}