$re = '/__(.*?)__/';
$str = 'The quick __grey__ fox jumps over the lazy __brown__ dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);