import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ # start of string\n"
+ "(?: # start of the non-capturing group\n"
+ " (?=.*\\d)(?=.*[A-Z])(?=.*[a-z]) # at least one digit, one upper, one lower\n"
+ "| # or\n"
+ " (?=.*\\d)(?=.*[^A-Za-z0-9])(?=.*[a-z]) # at least one digit, one non-ASCII alnum char, one lower\n"
+ "| # or\n"
+ " (?=.*[^A-Za-z0-9])(?=.*[A-Z])(?=.*[a-z]) # at least one non-ASCII alnum char, one upper, one lower\n"
+ "| # or\n"
+ " (?=.*\\d)(?=.*[A-Z])(?=.*[^A-Za-z0-9]) # at least one digit, one upper, one non-ASCII alnum char \n"
+ ")\n"
+ "(?!.*(.)\\1{2,}) # no 3 identical consecutive chars other than line break chars\n"
+ "[A-Za-z0-9]{8,64} # 8 to 64 alphanumeric\n"
+ "$ # end of string";
final String string = "123456asdfDDFD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}