$re = '/^ # start of string
(?: # start of the non-capturing group
(?=.*\d)(?=.*[A-Z])(?=.*[a-z]) # at least one digit, one upper, one lower
| # or
(?=.*\d)(?=.*[^A-Za-z0-9])(?=.*[a-z]) # at least one digit, one non-ASCII alnum char, one lower
| # or
(?=.*[^A-Za-z0-9])(?=.*[A-Z])(?=.*[a-z]) # at least one non-ASCII alnum char, one upper, one lower
| # or
(?=.*\d)(?=.*[A-Z])(?=.*[^A-Za-z0-9]) # at least one digit, one upper, one non-ASCII alnum char
)
(?!.*(.)\1{2,}) # no 3 identical consecutive chars other than line break chars
[A-Za-z0-9]{8,64} # 8 to 64 alphanumeric
$ # end of string/mx';
$str = '123456asdfDDFD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);