import Foundation
let pattern = ##"""
^ # start of string
(?: # start of the non-capturing group
(?=.*\d)(?=.*[A-Z])(?=.*[a-z]) # at least one digit, one upper, one lower
| # or
(?=.*\d)(?=.*[^A-Za-z0-9])(?=.*[a-z]) # at least one digit, one non-ASCII alnum char, one lower
| # or
(?=.*[^A-Za-z0-9])(?=.*[A-Z])(?=.*[a-z]) # at least one non-ASCII alnum char, one upper, one lower
| # or
(?=.*\d)(?=.*[A-Z])(?=.*[^A-Za-z0-9]) # at least one digit, one upper, one non-ASCII alnum char
)
(?!.*(.)\1{2,}) # no 3 identical consecutive chars other than line break chars
[A-Za-z0-9]{8,64} # 8 to 64 alphanumeric
$ # end of string
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"123456asdfDDFD"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)