const regex = /(\d+)\s?([^\d]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s?([^\\d]*)', 'gm')
const str = `838123 someWord 8 someWord 12 someWord
43434 of someword 12 anything someword 2323 new someword`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}