re = /(\d+)\s?([^\d]*)/m
str = '838123 someWord 8 someWord 12 someWord
43434 of someword 12 anything someword 2323 new someword'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end