import re
regex = re.compile(r"(\d+)\s?([^\d]*)", flags=re.MULTILINE)
test_str = ("838123 someWord 8 someWord 12 someWord\n"
"43434 of someword 12 anything someword 2323 new someword")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")