#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\S.*(?:\s*^ \S.*)+"
Local $sString = "yada yada yada" & @CRLF & _
"" & @CRLF & _
"date time somemethod EXC somenumber sometext R:System.NullReferenceException: Object reference not set to an instance of an object." & @CRLF & _
" at sometext in somepath .cs:line somenumber System.NullReferenceException: Object reference not set to an instance of an object." & @CRLF & _
" at sometext in Somepath .cs:line somenumber " & @CRLF & _
"" & @CRLF & _
"yada yada yada" & @CRLF & _
"" & @CRLF & _
"date time somemethod EXC somenumber sometext R:System.NullReferenceException: Object reference not set to an instance of an object." & @CRLF & _
" at sometext in somepath .cs:line somenumber System.NullReferenceException: Object reference not set to an instance of an object." & @CRLF & _
" at sometext in Somepath .cs:line somenumber "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")