import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^\\S.*(?:\\s*^ \\S.*)+";
final String string = "yada yada yada\n\n"
+ "date time somemethod EXC somenumber sometext R:System.NullReferenceException: Object reference not set to an instance of an object.\n"
+ " at sometext in somepath .cs:line somenumber System.NullReferenceException: Object reference not set to an instance of an object.\n"
+ " at sometext in Somepath .cs:line somenumber \n\n"
+ "yada yada yada\n\n"
+ "date time somemethod EXC somenumber sometext R:System.NullReferenceException: Object reference not set to an instance of an object.\n"
+ " at sometext in somepath .cs:line somenumber System.NullReferenceException: Object reference not set to an instance of an object.\n"
+ " at sometext in Somepath .cs:line somenumber ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}