using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^\S.*(?:\s*^ \S.*)+";
string input = @"yada yada yada
date time somemethod EXC somenumber sometext R:System.NullReferenceException: Object reference not set to an instance of an object.
at sometext in somepath .cs:line somenumber System.NullReferenceException: Object reference not set to an instance of an object.
at sometext in Somepath .cs:line somenumber
yada yada yada
date time somemethod EXC somenumber sometext R:System.NullReferenceException: Object reference not set to an instance of an object.
at sometext in somepath .cs:line somenumber System.NullReferenceException: Object reference not set to an instance of an object.
at sometext in Somepath .cs:line somenumber ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}