#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(https?\:.+?\.mpg[^2])"
Local $sString = ""settings":[{"id":"9238","title":"Black","sources":[{"format":"mpg2","url":"https:\/\/s3.us-east-1.amazonaws.com\/lostsound-community\/public\/59772318915193347298.mpg2"},{"format":"mpg","url":"https:\/\/s3.us-east-1.amazonaws.com\/lostsound-community\/public\65668314728130915134.mpg"}]},{"id":"9276","title":"Green","sources":[{"format":"mpg2","url":"https:\/\/s3.us-east-1.amazonaws.com\/lostsound-community\/public\/11915080088641193967.mpg2"},{"format":"mpg","url":"https:\/\/s3.us-east-1.amazonaws.com\/lostsound-community\/public\/09079955782489631046.mpg"}]},{"id":"9285","title":"White","sources":[{"format":"mpg2","url":"http:\/\/s3.us-east-1.amazonaws.com\/lostsound-community\/public\/53474438204706089576.mpg2"},{"format":"mpg","url":"http:\/\/s3.us-east-1.amazonaws.com\/lostsound-community\/public\/02262238689944761953.mpg"}]},"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")