# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(https?\:.+?\.mpg[^2])"
test_str = "\"settings\":[{\"id\":\"9238\",\"title\":\"Black\",\"sources\":[{\"format\":\"mpg2\",\"url\":\"https:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\/59772318915193347298.mpg2\"},{\"format\":\"mpg\",\"url\":\"https:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\65668314728130915134.mpg\"}]},{\"id\":\"9276\",\"title\":\"Green\",\"sources\":[{\"format\":\"mpg2\",\"url\":\"https:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\/11915080088641193967.mpg2\"},{\"format\":\"mpg\",\"url\":\"https:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\/09079955782489631046.mpg\"}]},{\"id\":\"9285\",\"title\":\"White\",\"sources\":[{\"format\":\"mpg2\",\"url\":\"http:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\/53474438204706089576.mpg2\"},{\"format\":\"mpg\",\"url\":\"http:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\/02262238689944761953.mpg\"}]},"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.