use strict;
my $str = '"settings":[{"id":"9238","title":"Black","sources":[{"format":"mpg2","url":"https:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\/59772318915193347298.mpg2"},{"format":"mpg","url":"https:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\65668314728130915134.mpg"}]},{"id":"9276","title":"Green","sources":[{"format":"mpg2","url":"https:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\/11915080088641193967.mpg2"},{"format":"mpg","url":"https:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\/09079955782489631046.mpg"}]},{"id":"9285","title":"White","sources":[{"format":"mpg2","url":"http:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\/53474438204706089576.mpg2"},{"format":"mpg","url":"http:\\/\\/s3.us-east-1.amazonaws.com\\/lostsound-community\\/public\\/02262238689944761953.mpg"}]},';
my $regex = qr/(https?\:.+?\.mpg[^2])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}