#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)>Title.*?<\/td>.*?<td>\K.*?(?=<\/td>)"
Local $sString = "<table> " & @CRLF & _
" <tr>" & @CRLF & _
" <td>Title</td>" & @CRLF & _
" <td>The Harsh Face of Mother Nature</td>" & @CRLF & _
" </tr>" & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")