re = />Title.*?<\/td>.*?<td>\K.*?(?=<\/td>)/
str = '<table>
<tr>
<td>Title</td>
<td>The Harsh Face of Mother Nature</td>
</tr>
.
.
.
</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end