import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w.]+=\\$\\d+(?:\\|[\\w.]+=\\$\\d+)*$";
final String string = "Valid Values:\n\n"
+ "ABC=$2|CDE=$1|Msg=$4|Ph.No=$3|TIME=$5\n\n"
+ "ABC=$2|CDE=$1|Msg123=$4|Ph.No=$3|TIME_23=$5\n\n"
+ "abc=$2|123=$1|cfg=$4|Ph.No=$3\n\n"
+ "ABC=$12|CDE=$1|Msg=$48|Ph.No=$3|TIME=$5\n\n"
+ "ABC=$22|CDE=$16|Msg123=$49|Ph.No=$3|TIME_23=$5\n\n"
+ "abc=$23|123=$51|cfg=$4|Ph.No=$03\n\n"
+ "Invalid Values:\n\n"
+ "ABC=$2CDE=$1Msg=$4\n\n"
+ "ABC=2|CDE=1|Msg123=$4|Ph.No=$3|TIME_23=$5\n\n"
+ "abc$2|123$1|cfg$4|Ph.No=$3\n\n"
+ "Msg123=$ |Ph.No=$ |TIME_23=5\n\n"
+ "abcdefgh|1234|eghjik\n\n"
+ "Msg123=$*|Ph.No=$()|TIME_23=$5\n\n"
+ "Msg123=$a|Ph.No=$b|TIME_23=$p";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}