$re = '/^[\w.]+=\$\d+(?:\|[\w.]+=\$\d+)*$/m';
$str = 'Valid Values:
ABC=$2|CDE=$1|Msg=$4|Ph.No=$3|TIME=$5
ABC=$2|CDE=$1|Msg123=$4|Ph.No=$3|TIME_23=$5
abc=$2|123=$1|cfg=$4|Ph.No=$3
ABC=$12|CDE=$1|Msg=$48|Ph.No=$3|TIME=$5
ABC=$22|CDE=$16|Msg123=$49|Ph.No=$3|TIME_23=$5
abc=$23|123=$51|cfg=$4|Ph.No=$03
Invalid Values:
ABC=$2CDE=$1Msg=$4
ABC=2|CDE=1|Msg123=$4|Ph.No=$3|TIME_23=$5
abc$2|123$1|cfg$4|Ph.No=$3
Msg123=$ |Ph.No=$ |TIME_23=5
abcdefgh|1234|eghjik
Msg123=$*|Ph.No=$()|TIME_23=$5
Msg123=$a|Ph.No=$b|TIME_23=$p';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);