// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w.]+=\$\d+(?:\|[\w.]+=\$\d+)*$").unwrap();
let string = "Valid Values:
ABC=$2|CDE=$1|Msg=$4|Ph.No=$3|TIME=$5
ABC=$2|CDE=$1|Msg123=$4|Ph.No=$3|TIME_23=$5
abc=$2|123=$1|cfg=$4|Ph.No=$3
ABC=$12|CDE=$1|Msg=$48|Ph.No=$3|TIME=$5
ABC=$22|CDE=$16|Msg123=$49|Ph.No=$3|TIME_23=$5
abc=$23|123=$51|cfg=$4|Ph.No=$03
Invalid Values:
ABC=$2CDE=$1Msg=$4
ABC=2|CDE=1|Msg123=$4|Ph.No=$3|TIME_23=$5
abc$2|123$1|cfg$4|Ph.No=$3
Msg123=$ |Ph.No=$ |TIME_23=5
abcdefgh|1234|eghjik
Msg123=$*|Ph.No=$()|TIME_23=$5
Msg123=$a|Ph.No=$b|TIME_23=$p";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}