# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ns\d+:([\w-]+)/$1/g;t' <<< "<?xml version=\"1.0\"?>
<Period>
<AllContacts>
<Entry>
<ns0:entity-Person>
<ns0:CellPhone>3095550101</ns0:CellPhone>
<ns0:FirstName>Brrzzz</ns0:FirstName>
<ns0:LastName>Grbbs</ns0:LastName>
</ns0:entity-Person>
<ns0:PrimaryPhone>mobile</ns0:PrimaryPhone>
</Entry>
</AllContacts>
<State>TX</State>
</Period>"