using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ns\d+:([\w-]+)";
string substitution = @"$1";
string input = @"<?xml version=""1.0""?>
<Period>
<AllContacts>
<Entry>
<ns0:entity-Person>
<ns0:CellPhone>3095550101</ns0:CellPhone>
<ns0:FirstName>Brrzzz</ns0:FirstName>
<ns0:LastName>Grbbs</ns0:LastName>
</ns0:entity-Person>
<ns0:PrimaryPhone>mobile</ns0:PrimaryPhone>
</Entry>
</AllContacts>
<State>TX</State>
</Period>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}