# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"ns\d+:([\w-]+)"
test_str = ("<?xml version=\"1.0\"?>\n"
"<Period>\n"
" <AllContacts>\n"
" <Entry>\n"
" <ns0:entity-Person>\n"
" <ns0:CellPhone>3095550101</ns0:CellPhone>\n"
" <ns0:FirstName>Brrzzz</ns0:FirstName>\n"
" <ns0:LastName>Grbbs</ns0:LastName>\n"
" </ns0:entity-Person>\n"
" <ns0:PrimaryPhone>mobile</ns0:PrimaryPhone>\n"
" </Entry>\n"
" </AllContacts>\n"
" <State>TX</State>\n"
"</Period>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.