using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(function)? ?\w+? ?(\(\))? *\n?\{";
string input = @"function abc_yzx_abs()
{
function abc_yzx_abs() {
function abc_yzx_abs()
{";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}