re = /^(function)? ?\w+? ?(\(\))? *\n?\{/m
str = 'function abc_yzx_abs()
{
function abc_yzx_abs() {
function abc_yzx_abs()
{'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end