$re = '/^(function)? ?\w+? ?(\(\))? *\n?\{/m';
$str = 'function abc_yzx_abs()
{
function abc_yzx_abs() {
function abc_yzx_abs()
{';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);