const regex = new RegExp('[^`\\'"?:]*
(?:
` [^`\\\\]*+ (?s:\\\\.[^`\\\\]*|``[^`\\\\]*)*+ `
[^`\\'"?:]*
|
\\' [^\\'\\\\]*+ (?s:\\\\.[^\\'\\\\]*|\\'\\'[^\\'\\\\]*)*+ \\'
[^`\\'"?:]*
|
" [^"\\\\]*+ (?s:\\\\.[^"\\\\]*|""[^"\\\\]*)*+ "
[^`\\'"?:]*
)* \\K (*SKIP)
(?:
\\?{1,2}
|
:{1,2}
([a-zA-Z_\\x7f-\\xff][a-zA-Z0-9_\\x7f-\\xff]*)
)', 'g')
const str = `INSERT INTO xyz WHERE
a=?
and b="wha\\"t?"
and ??="cheese"
and \`col?\`='OK'
and ::col='another'
and last!=:least`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}