# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
[^`'"?:]*
(?:
` [^`\\]*+ (?s:\\.[^`\\]*|``[^`\\]*)*+ `
[^`'"?:]*
|
' [^'\\]*+ (?s:\\.[^'\\]*|''[^'\\]*)*+ '
[^`'"?:]*
|
" [^"\\]*+ (?s:\\.[^"\\]*|""[^"\\]*)*+ "
[^`'"?:]*
)* \K (*SKIP)
(?:
\?{1,2}
|
:{1,2}
([a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*)
)
"""
test_str = ("INSERT INTO xyz WHERE \n"
"a=? \n"
"and b=\"wha\\\"t?\"\n"
"and ??=\"cheese\"\n"
"and `col?`='OK'\n"
"and ::col='another'\n"
"and last!=:least")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.