import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\/\\*+[^*]*\\*+(?:[^\\/*][^*]*\\*+)*\\/\\r?\\n)?.*[;,]$";
final String string = "/**\n"
+ " * Here there's a comment I don't want to find,\n"
+ " * but after this comment I do\n"
+ " */\n"
+ "detectMe;\n"
+ "other,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}