$re = '/(?:\/\*+[^*]*\*+(?:[^\/*][^*]*\*+)*\/\r?\n)?.*[;,]$/m';
$str = '/**
* Here there\'s a comment I don\'t want to find,
* but after this comment I do
*/
detectMe;
other,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);