re = /(?:\/\*+[^*]*\*+(?:[^\/*][^*]*\*+)*\/\r?\n)?.*[;,]$/m
str = '/**
* Here there\'s a comment I don\'t want to find,
* but after this comment I do
*/
detectMe;
other,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end